Ticket #150 (closed task: fixed)

Opened 9 years ago

Last modified 9 years ago

Check if names of duplicated MOs are retrieved

Reported by: michelpons Owned by: Michael Halloran
Priority: major Milestone: 2.2
Component: COLoggers Version: Development
Keywords: Duplicate Cc: michaelhalloran

Description

I am opening up in Aspen Plus v7.3.2 a case file that makes use of Aspen Plus embedded thermo and of the VB6 Mixer Splitter example used as a splitter. I run the case and analyze the log file obtained with COLTT 2.1 Build 246.

Within the Calculate call, there is a call to Duplicate the MO named as 1:

MaterialObject <1> : Call to Duplicate
MaterialObject Duplicate returns clone: 013A43B0
MaterialObject <1> : Return from Duplicate - Succeeded

Once this is done I presume that most subsequent CalcProp and CalcEquilibrium calls are made on the duplicated MO. However the following is logged:

MaterialObject <1> : Call to CalcProp requesting:

Property Phase Calc
enthalpy Liquid mixture

MaterialObject <1> : Return from CalcProp - Succeeded

I wonder if COLTT has really updated the name of the MO, or if the duplicated MO has the same component_Name as the original MO. I can't see any call to get_componentName on the ICapeIdentification interface carried by the duplicated MO. Would be necessary to know what is going on. If the duplicated MO is given the same name as the original MO by the PME, it may induce some recommendation to developers to avoid that situation.

Attachments

apmain_091212_180212.zip (14.3 KB) - added by michelpons 9 years ago.
Zipped log file obtained with COLTT 2.1 Build 246
Connected.zip (147.5 KB) - added by michelpons 9 years ago.
zipped apw file for Aspen Plus 7.3.2
Connected.bkp (11.9 KB) - added by michelpons 9 years ago.
bkp file for Aspen Plus 7.3.2
Connected.def (217 bytes) - added by michelpons 9 years ago.
def file for Aspen Plus 7.3.2

Change History

Changed 9 years ago by michelpons

Zipped log file obtained with COLTT 2.1 Build 246

Changed 9 years ago by michelpons

zipped apw file for Aspen Plus 7.3.2

Changed 9 years ago by michelpons

bkp file for Aspen Plus 7.3.2

Changed 9 years ago by michelpons

def file for Aspen Plus 7.3.2

comment:1 Changed 9 years ago by michaelhalloran

  • Status changed from new to closed
  • Resolution set to fixed

If the PME gives the duplicate MO a unique name it will be used in the log, if the PME does not rename the duplicate COLTT will log it as <duplicate of ...>. Aspen Plus 7.3 does not rename duplicates. Fixed with commit 253 and available in builds after 16th September.

Note: See TracTickets for help on using tickets.