Ticket #78 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

When UO logged no connection on ports

Reported by: michelpons Owned by: michaelhalloran
Priority: major Milestone: 2.0 No dependency/Viewer/New installer
Component: COLoggers Version: Development
Keywords: Cc:

Description

The PME used is Aspen Plus 7.2. The PMC used is a UO in .NET made by DTU/CERE. The scenario is to start from a Aspen Plus case where two streams are defined, one to serve as input, the other as output. Without COLTT enabled on the UO, it is possible to connect the defined stream to the UO inlet and to connect the other stream to the outlet port. The UO is then considered as valid and calculation may be launched. Calculation ends up with an error: the material flow in the outlet stream is way too large compared to the material flow in the inlet stream. That calls for a look with COLTT. When COLTT is enabled on the UO, it is impossible to connect streams to ports, so it is impossible to reach the point where the calculation is made.

Attachments

UnconnectedMixerv72.bkp (11.2 KB) - added by michelpons 9 years ago.
Aspen Plus v7.2 input file
MyHistory.txt (10.0 KB) - added by michelpons 9 years ago.
History file obtained without COLTT enabled on UO
apmain_051811_220130.log (4.5 KB) - added by michelpons 9 years ago.
Log file obtained
SimpleMixer_180511.zip (10.5 KB) - added by michelpons 9 years ago.
Zipped .NET project
apmain_060111_094633.log (19.1 KB) - added by michelpons 9 years ago.
Log obtained with COLTT build May 30, 2011

Change History

Changed 9 years ago by michelpons

Aspen Plus v7.2 input file

Changed 9 years ago by michelpons

History file obtained without COLTT enabled on UO

Changed 9 years ago by michelpons

Log file obtained

Changed 9 years ago by michelpons

Zipped .NET project

comment:1 Changed 9 years ago by michelpons

  • Status changed from new to closed
  • Resolution set to fixed

Michael, as per your message of May 30: \"I suspect this problem was also caused by the parameter collection failure. The log shows a call to count on the parameter collection, followed by a call to Terminate. I think apmain has crashed because of the null pointer, but it's exit handler traps the crash and then cleans up hence the call to Terminate. Can you try this one again and see if it is any different?\". I have installed COLTT 1.08.05 build dated May 30, 2011 and I have rerun the scenario that involves the UO from CERE. I just used a most recent version of the UO that sets properties only on a mole basis.
As shown in the new log file attached, it is now possible, when the log of the CERE UO is enabled, to connect streams to ports. COLTT manages fine the NULL pointer received for the Parameter Collection. So the issue is resolved.

Changed 9 years ago by michelpons

Log obtained with COLTT build May 30, 2011

comment:2 Changed 9 years ago by michelpons

  • Milestone set to 1.08.05
Note: See TracTickets for help on using tickets.