Ticket #24 (closed defect: Not Reproducible)

Opened 11 years ago

Last modified 11 years ago

09-006 HDPE Reactor in Aspen Plus

Reported by: michelpons Owned by: Michael Halloran
Priority: major Milestone: Refactoring
Component: COLoggers Version: 1.08.2
Keywords: Cc: michaelhalloran

Description

De: Michel Pons [technologyofficer@…]
Envoyé: Tuesday, May 19, 2009 9:13 AM
À: 'Ahsan Akhtar'
Cc: 'michaeljhalloran@…'
Objet: RE: Friday Session

Ahsan,

Sorry for the delay but I was tied up by other tasks.

I have transferred the DLL you sent to the COLTT 09-006 VM and I have run the scenario. I can only report that it does not work any better. I can’t display the list of parameters for the UO and the live log screen in COLTT controller remains empty.

Best regards

Michel
=========================================================
De: Ahsan Akhtar [ahsan.akhtar@…]
Envoyé: Friday, May 15, 2009 8:10 AM
À: 'Michel Pons'
Objet: FW: Friday Session

Michel,

I am writing this email just to check whether you get a chance to test the issue 09-006 with the updated DLL?

Best Regards

Ahsan
========================================================
De: Ahsan Akhtar [ahsan.akhtar@…]
Envoyé: Wednesday, May 13, 2009 12:47 PM
À: 'Michel Pons'
Objet: Friday Session

Pièces jointes: COLoggersST.dll

Michel,

May I request you to test the case 09-006 with the attached DLL on the VM on which I had a session on last Friday. If you remember, on Friday session, COLTT was causing a problem in displaying parameters and was showing blank window, due to which I stopped debugging the case.

Best Regards

Ahsan
===========================================================
De: Michel Pons [technologyofficer@…]
Envoyé: Thursday, May 07, 2009 7:48 PM
À: 'sidathyder5@…'
Objet: RE: PCNow Session

Ahsan,

Go to sleep. I will find the number. Have a good night.

Best regards

Michel
=======================================================
De: Ahsan Akhtar [sidathyder5@…]
Envoyé: Thursday, May 07, 2009 7:46 PM
À: Michel Pons
Objet: Re: PCNow Session
I think u can copy the source code from VM prepared for issue of FTN mixer in aspen hysys

I don't remember the issue no. Actually I am going to sleep as it is late night here at Pakistan. But if u need no I can open my note book?

Best regards

Ahsan
=========================================================
De: Michel Pons [technologyofficer@…]
Envoyé: Thursday, May 07, 2009 6:48 PM
À: 'Ahsan Akhtar'
Cc: 'Michael Halloran'
Objet: RE: PCNow Session

Ahsan,

OK for a session tomorrow morning, May 8.

I have a virtual machine set up for COLTT issue 09-006 with VS2008 Express edition installed as well as TOTAL HDPEReactor and Aspen Plus 7.1. However I don’t know where to get the proper version of the 1.08.02 COLTT source code. Could you send me a link from which I could download the source code before the session takes place?

I have also virtual machines for issues 09-008 and 09-009.

Best regards

Michel
===========================================================
De: Ahsan Akhtar [ahsan.akhtar@…]
Envoyé: Thursday, May 07, 2009 10:59 AM
À: 'Michel Pons'
Objet: PCNow Session

Michel,

Is it possible for you to have a session tomorrow morning at 8.00 am Paris time?

I want to debug and fix the issue 09-006. I will need TOTAL HDPEReactor and Aspen Plus v7.1 components installed on the machine. I will also need VS2008 and COLTT source code on that machine.

I will also run 09-008 and 09-009 issues to check if these are fixed.

Best Regards

Ahsan
=========================================================
De: Michael Halloran [michaeljhalloran@…]
Envoyé: Saturday, April 25, 2009 7:28 PM
À: Michel Pons
Cc: Ahsan Akhtar
Objet: Re: TOTAL HDPEReactor in Aspen Plus v7.1
Michel, Ahsan,

I haven't seen a response to this yet so I took a look at this problem.

The final crash seems to occur in GetComponentConstant in MaterialObjectSt.cpp this code has not changed between 1.07 and 1.08.2 comparing my 1.08 copy and the 1.07 copy on sourceforge.net. As Michel notes what has changed is that the log in 1.08.2 is larger. That's because more information is being generated by the newer version, for example calls to unsupported interface are all now logged and there are a lot of them everytime a parameter is accessed.

Since the code hasn't changed I think this one has to be debugged on the Co-Lan laptop; it could be some sort of corruption caused by the code generating the new output.

Regards
Michael
================================================================
De: Michel Pons [technologyofficer@…]
Envoyé: Tuesday, April 14, 2009 4:56 PM
À: 'Ahsan Akhtar'
Cc: 'michaeljhalloran@…'
Objet: TOTAL HDPEReactor in Aspen Plus v7.1

Pièces jointes: apmain_041409_162341v107.zip; Scenario.doc; apmain_041409_163539v10802.zip; Debugassertionfailed.doc

Ahsan,

I have encountered a major difference in using COLTT v1.07 and COLTT v1.08.02 when enabled on a Unit Operation provided by TOTAL. The Unit Operation is working with CAPE-OPEN Thermo 1.0 in Aspen Plus. Since the simulation ends up with errors, I have used COLTT in order to figure out what goes on. The scenario is quite simple (see Scenario.doc), starting from an Aspen Plus document that contains the necessary feed streams and setting up the connections. The unusual thing is that Edit does not work on such a UO and one needs to right-click on the block and select “input” to proceed with changing a parameter. Odd behaviour still not fixed in Aspen Plus v7.1.

Using COLTT v.1.07 seems fine, providing the same behaviour with and without COLTT enabled on the UO and providing a log file (see apmain_041409_162341v107 in the zipped file attached).

Now with COLTT v1.08.02, I get a much larger log (apmain_041409_163539v10802 in the zipped file attached) but a debug assertion error message when selecting the UO and subsequently Aspen Plus crashes (see Debugassertionfailed.doc attached).

So this shows some kind of regression from v1.07 to v1.08.02 that should be looked upon.

I am giving number 09-006 to this issue since there is also a non-numbered issue on the blank screen in COLTT controller that should be numbered 09-005 (sent on April 9). I am setting up a VM with the necessary software for further tests on 09-006.

Best regards

Michel

Attachments

apmain_041409_162341v107.zip (61.9 KB) - added by michelpons 11 years ago.
Zipped log file obtained with COLTT 1.07
apmain_041409_163539v10802.zip (94.8 KB) - added by michelpons 11 years ago.
Zipped log file obtained with COLTT 1.08.02
apmain_102409_180032_v10803.zip (122.3 KB) - added by michelpons 11 years ago.
Zipped log file obtained with COLTT 1.08.03
Debugassertionfailed.doc (49.0 KB) - added by michelpons 11 years ago.
Screen copy

Change History

Changed 11 years ago by michelpons

Zipped log file obtained with COLTT 1.07

Changed 11 years ago by michelpons

Zipped log file obtained with COLTT 1.08.02

Changed 11 years ago by michelpons

Zipped log file obtained with COLTT 1.08.03

Changed 11 years ago by michelpons

Screen copy

comment:1 Changed 11 years ago by michelpons

I have rerun the case with COLTT 1.08.03. I observe that with COLTT enabled on the HDPE Reactor UO, the behaviour is the same as without COLTT enabled. So the defect observed with COLTT 1.08.02 has been resolved by COLTT 1.08.03. I have attached the log file obtained (apmain_102409_180032_v10803.zip).

I recommend closing this defect.

comment:2 Changed 11 years ago by michaelhalloran

  • Status changed from new to closed
  • Resolution set to Not Reproducible

Closed as recommended.

comment:3 Changed 11 years ago by michelpons

  • Milestone set to Refactoring
Note: See TracTickets for help on using tickets.