Ticket #23 (closed defect: Not Reproducible)

Opened 11 years ago

Last modified 11 years ago

09-003 FTNMixer in Aspen Hysys

Reported by: michelpons Owned by: Michael Halloran
Priority: major Milestone: Refactoring
Component: COLoggers Version: 1.08.2
Keywords: Cc: michaelhalloran

Description

De: Ahsan Akhtar [sidathyder5@…]
Envoyé: Friday, April 10, 2009 6:52 PM
À: Michel Pons
Objet: Re: VS2008 Express edition
Michel,

Yes, fine with me

Best regards

Ahsan
============================================================
De: Michel Pons [technologyofficer@…]
Envoyé: Friday, April 10, 2009 6:03 PM
À: 'sidathyder5@…'
Objet: RE: VS2008 Express edition

Ahsan,

Both virtual machines, COLTT09-003 and COLTT09-004, have been equipped with VS 2008 C++ Express Edition and the relevant PMCs and PME for each case.

I will send you an invitation for the session. No need for you to connect to PCNow website. Will be able to start at 08:30 AM Paris time. Is that fitting your schedule?

Best regards

Michel
============================================================
De: Michel Pons [technologyofficer@…]
Envoyé: Friday, April 10, 2009 11:39 AM
À: 'sidathyder5@…'
Objet: RE: VS2008 Express edition

Ahsan,

Just to be sure we understand each other : I can only install the Express Edition not the full edition for VS2008.

Best regards

Michel
=============================================================
De: Ahsan Akhtar [sidathyder5@…]
Envoyé: Friday, April 10, 2009 11:27 AM
À: Michel Pons
Objet: Re: VS2008 Express edition
Yes, Pls install VS2008, relevant PME and PMC on the VM.

Best Regards

Ahsan
==========================================================
De: Michel Pons [technologyofficer@…]
Envoyé: Friday, April 10, 2009 10:09 AM
À: 'Ahsan Akhtar'
Cc: 'Michael Halloran'
Objet: VS2008 Express edition

Ahsan,

What should I do in the virtual machines set up for issues 09-003 and 09-004? Should I install VS 2008 C++ Express Edition in there? I need to do this today if you will need it on Tuesday.

Best regards

Michel
===========================================================
De: Ahsan Akhtar [ahsan.akhtar@…]
Envoyé: Thursday, April 09, 2009 2:55 PM
À: 'Michel Pons'
Objet: New Issues

Michel,

I have recorded following issue in the register:

09-002 Suspected memory leak problem in the utility program provided by CO-LAN
09-003 When COLTT is enabled on Unit Operation made with the FORTRAN Wizard in Aspen Hysys v7.1, Aspen Hysys closes down because of a crash after accepting the UO.
09-004 When COLTT is enabled on Simulis Thermodynamics Thermo System in Aspen Hysys 2004, upon loading the same Aspen Hysys case file, a message 'ERROR: Internal error creating a CAPEOPEN property package' is being displayed.

Is it possible that I can debug issue 09-003 and 09-004 on CO-LaN laptop coming Monday? (please note that I will need VS2008 on the laptop).

Best Regards

Ahsan
============================================================
De: Michael Halloran [michaeljhalloran@…]
Envoyé: Wednesday, April 08, 2009 10:40 PM
À: Michel Pons
Cc: Ahsan Akhtar
Objet: Re: Simulis Thermodynamics in Aspen Hysys 2004
Michel,

Do you have any example where COLTT 1.08 works in Hysys as you would expect? The reason I ask is that the log attached here ends at exactly the same point as the log you attached to the previous case which involved a Unit Operation. I'm wondering whether these two have something in common even though they involve a Unit and a Property Package.

Regards
Michael
=============================================================
De: Michel PONS via YouSendIt [delivery@…]
Envoyé: Wednesday, April 08, 2009 9:39 AM
À: technologyofficer@…
Objet: File Sent: FTNMixerSetup.exe

youSENDit File Sent
Thank you for trusting YouSendIt to send your important files.
Want to send and track multiple files at once?

Upgrade Now


.......................................................................................................................................................................................................................

File sent: FTNMixerSetup.exe
Recipients sent to: ahsan.akhtar@…
File will be stored for: 7 days



Link to file:
http://download.yousendit.com/WnBRclVFNkdQb0pMWEE9PQ



YouSendIt Inc. | Terms of Service | Privacy Policy | DMCA Policy | Opt Out

1919 S. Bascom Avenue, 3rd Floor Campbell, CA 95008

================================================================
De: Michel Pons [technologyofficer@…]
Envoyé: Wednesday, April 08, 2009 9:35 AM
À: 'Ahsan Akhtar'
Cc: 'Michael Halloran'
Objet: FTNMixer in Aspen Hysys v7.1

Pièces jointes: Screenshots.doc; hysys_040809_085646.log

Ahsan,

I have tried COLTT v1.08 on the combination made of a Unit Operation made with the FORTRAN Wizard and Aspen Hysys v7.1. On this combination (without COLTT enabled) I have an issue as you may see in the attached Word document. The UO does not load up in Aspen Hysys v7.1. There is a load error but apart from that there is no Aspen Hysys crash. I wanted to investigate further with COLTT what was happening.

I have enabled COLTT on the Fortran UO. I have followed the same scenario. What happens is that, instead of getting the load error message sent by Aspen Hysys, I have Aspen Hysys closing down because of a crash after accepting the UO. I don’t see the load error message. In COLTT controller, the real-time view is kept blank. However I got a small log file in Application Data
COLTT. See attached.

So there is a significant difference of behaviour with and without COLTT enabled on the Unit Operation. Since the Unit Operation can’t be loaded in Aspen Hysys even when not logged, this may be a special case but nevertheless.

The Unit Operation used here is accepting only Thermo 1.1 Property packages. I guess that at the load stage this has no effect. I will send you the installer for the Unit Operation separately.

Will need an issue number for that case.

Best regards

Michel

Attachments

hysys_040809_085646_v10802.log (912 bytes) - added by michelpons 11 years ago.
Log file obtained with COLTT 1.08.02
hysys_102409_161136_v10803.log (1.4 KB) - added by michelpons 11 years ago.
Log file obtained with COLTT 1.08.03

Change History

Changed 11 years ago by michelpons

Log file obtained with COLTT 1.08.02

comment:1 Changed 11 years ago by michelpons

I have used COLTT 1.08.03 (Build Oct 19, 2009) on the combination of FTNMixer and Aspen Hysys. I have observed that now, with COLTT enabled on the FTNMixer UO, I get strictly the same behaviour as without COLTT enabled on the FTNMixer UO, meaning that the UO can't be loaded. I have attached the log file obtained in that case (hysys_102409_161136_v10803.log).

My recommendation is to close this issue since the defect occurring with COLTT 1.08.02 has been resolved.

Changed 11 years ago by michelpons

Log file obtained with COLTT 1.08.03

comment:2 Changed 11 years ago by michaelhalloran

  • Status changed from new to closed
  • Resolution set to Not Reproducible

Michel,

the 1.08.3 log shows that the unit does get loaded but then returns an error when put_simulationContext is called. Perhaps Hysys can't deal with this circumstance? What happens if you change the example to return success for this call? It won't make any difference to the execution because the simulationContext interface is the UO to use only, and your example won't be using it.

Closing this defect anyway as the reported behaviour is not reproducible in 1.08.3

comment:3 Changed 11 years ago by michelpons

Michael,

I can't change the behaviour of the FTNMixer: was done in FORTRAN90 with the FORTRAN Wizard by ProSim SA and I have not a FORTRAN90 compiler to redo it. On the other hand Aspen Hysys 7.2 should resolve a number of such issues (impossible to load various UOs). So I will check what happens with Aspen Hysys 7.2 (I am supposed to get a beta version on November 11 through Hiren Shethna).

comment:4 Changed 11 years ago by michelpons

  • Milestone set to Refactoring
Note: See TracTickets for help on using tickets.