Ticket #125 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

Dubious message upon error detection on GetCompoundConstant

Reported by: michelpons Owned by: Michael Halloran
Priority: major Milestone: 2.1
Component: COLoggers Version: Development
Keywords: Cc: michaelhalloran

Description

I am using Aspen Hysys 7.3 CP2 and a specially developed PPM based on the thermo examples distributed by CO-LaN. The PPM is returning an empty list of constant properties (return on GetConstPropList call) and then Aspen Hysys calls GetCompoundConstant. This apparently raises an error.

COLTT 2.1 build June 5, 2012 says the followinh:
PropertyPackage <Anonymous> : Call to GetCompoundConstant

GetCompoundConstant takes Input Arguments:

Error - compIds argument should be of type VT_ARRAY|VT_BOOL not VT_ARRAY|VT_BSTR

GetCompoundConstant returns:

Property Compounds ValueReturned

Warning - propvals argument is empty

PropertyPackage <Anonymous> : Return from GetCompoundConstant - Succeeded

I think the compIds argument should not be a boolean. So may be the message has to be reversed (I don't know what Aspen Hysys is using though). Installer for the PPM as well as instructions to install and use will be delivered through other communication means.

COLTT version 2.0 did not mention an error, i.e. no test was apparently made.

Attachments

hysys_060712_215445.log (24.2 KB) - added by michelpons 10 years ago.
Log file obtained with COLTT 2.0 as released
hysys_060712_224233.log (21.9 KB) - added by michelpons 10 years ago.
Log file obtained with COLTT 2.1 build June 5, 2012
hysys_061812_113803.log (21.9 KB) - added by michelpons 10 years ago.
Log file obtained with COLTT 2.1 Build June 16, 2012

Change History

Changed 10 years ago by michelpons

Log file obtained with COLTT 2.0 as released

Changed 10 years ago by michelpons

Log file obtained with COLTT 2.1 build June 5, 2012

comment:1 Changed 10 years ago by michaelhalloran

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in June 16th Build

comment:2 Changed 10 years ago by michelpons

I have installed COLTT 2.1 Build June 16, 2012 and I have proceeded with running again the scenario. The log file now states:

PropertyPackage <Anonymous> : Call to GetConstPropList

Warning - props argument is empty

PropertyPackage <Anonymous> : Return from GetConstPropList - Succeeded
PropertyPackage <Anonymous> : Call to GetCompoundConstant

GetCompoundConstant takes Input Arguments:

Warning - props argument is an empty array

Property Compounds

GetCompoundConstant returns:

Property Compounds ValueReturned

Warning - propvals argument is empty

PropertyPackage <Anonymous> : Return from GetCompoundConstant - Succeeded

which seems adequate since the PPM used is made to return empty for propslist and then Aspen Hysys 7.2 uses this empty list to call GetCompoundConstant. The issue is consequently fixed. I am attaching to this ticket the log file obtained with COLTT 2.1 Build June 16, 2012.

Changed 10 years ago by michelpons

Log file obtained with COLTT 2.1 Build June 16, 2012

Note: See TracTickets for help on using tickets.