Ticket #126 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

Incomplete information out of GetComponentConstant call

Reported by: michelpons Owned by: Michael Halloran
Priority: major Milestone: 2.1
Component: COLoggers Version: Development
Keywords: GetComponentConstant Cc: michaelhalloran

Description

I am investigating an issue that appeared initially when using an Aspen Properties Property Package out of version 7.3.2 from Aspen Plus in HTRI Xchanger Suite 6.0. I have transformed the scenario so that I am using COFE instead of XChanger. COFE crashes (with or without COLTT enabled on Aspen Properties Thermo System) when accessing the info on a compound. The document expliciting the scenario will be emailed separately. I am puzzled by the lack of info showing from the GetComponentConstant calls. For example:

PropertyPackage <Anonymous> : Call to GetComponentConstant requesting these constants :

iupacName

MaterialObject <Anonymous> : Call to get_ComponentIds

get_ComponentIds returns :
ETHANOL
WATER

MaterialObject <Anonymous> : Return from get_ComponentIds - Succeeded
PropertyPackage <Anonymous> : GetComponentConstant returns

It looks like there is no return but I can't tell what is actually returned. At some point, when the property \"acentric factor\" is requested, COFE crashes. Can't tell why. I would appreciate if COLTT would show more. Don't know if it is possible.

Attachments

cofe_060812_202122.log (10.2 KB) - added by michelpons 10 years ago.
Log file obtained with COLTT 2.1 Build June 5, 2012
cofe_061812_100023.log (10.3 KB) - added by michelpons 10 years ago.
Log file obtained with COLT 2.1 Build June 16, 2012

Change History

Changed 10 years ago by michelpons

Log file obtained with COLTT 2.1 Build June 5, 2012

comment:1 Changed 10 years ago by michaelhalloran

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in June 16th build.

comment:2 Changed 10 years ago by michelpons

I have installed COLTT 2.1 Build June 16, 2012 and rerun the scenario. Now I obtain a log file which shows what is returned by GetComponentConstant when the method does not throw an exception, i;e. for iupacName and CAS number. So indeed the issue is resolved. I am attaching the log file obtained with the June 16 build as a matter of completeness.

Changed 10 years ago by michelpons

Log file obtained with COLT 2.1 Build June 16, 2012

Note: See TracTickets for help on using tickets.