Ticket #93 (closed enhancement: fixed)

Opened 9 years ago

Last modified 9 years ago

Support for IPersistPropertyBag

Reported by: michelpons Owned by: michaelhalloran
Priority: major Milestone: 2.0 No dependency/Viewer/New installer
Component: COLoggers Version: Development
Keywords: persistence Cc:

Description

There is at least one major commercial PME which is relying, but not only, on IPersistPropertyBag. Logging for this persistence interface is not supported by version 1.08.5 of COLTT. May be worth developing the suitable logger.

Attachments

proii_090711_181504_feedconnected.zip (23.9 KB) - added by michelpons 9 years ago.
Zipped log file showing IPersistPropertyBag as not logged
proii_091111_112130.log (174.1 KB) - added by michelpons 9 years ago.
Log file obtained with COLTT v2.0 Build Sep 10, 2011

Change History

comment:1 Changed 9 years ago by anonymous

Michel, do you have a log to go with this? IPersistPropertyBag is supported in 1.08.5 as are all the flavours of persistence interface.

Changed 9 years ago by michelpons

Zipped log file showing IPersistPropertyBag as not logged

comment:2 Changed 9 years ago by michelpons

A zipped log file obtained with PRO/II 9.1 has been attached to the ticket.

comment:3 Changed 9 years ago by michelpons

  • Milestone set to 2.00 No dependency/Viewer/New installer

comment:4 Changed 9 years ago by anonymous

  • Status changed from new to closed
  • Resolution set to fixed

Duplicate of #6; fixed in 2.0 release.

comment:5 Changed 9 years ago by michelpons

With COLTT v2.0 Build Sep 10, 2011, I confirm that queries on IPersistPropertyBag are properly logged:

Unit <Anonymous> : Call to QueryInterface

Requested Interface : IPersistPropertyBag

Unit <Anonymous> : Error returned from QueryInterface - 0x80004002

See the attached log file obtained with PRO/II.

Changed 9 years ago by michelpons

Log file obtained with COLTT v2.0 Build Sep 10, 2011

Note: See TracTickets for help on using tickets.