Ticket #86 (closed defect: worksforme)

Opened 10 years ago

Last modified 9 years ago

Return from SetProp not logged

Reported by: michelpons Owned by: michaelhalloran
Priority: major Milestone: 2.0 No dependency/Viewer/New installer
Component: COLoggers Version: Development
Keywords: SetProp mass Cc:

Description

I am using a Simulis Thermodynamics Property Package adhering to CAPE-OPEN 1.0 in UniSim Design. I am making a simple flash on a stream. UniSim Design is calling addtional property calculations in order to fill its properties display. Just after the last CalcEquilibrium call logged in the log file, UniSim Design requests a enthalpy calculation on the vapor phase. Simulis PP gets the compound IDs, overall temperature, overall pressure, vapor phase composition and then sets the enthalpy for vapor phase in the MO on a molar basis and then on a mass basis. In the log I don't see the last SetProp being returned. Still other calls are then logged. What can be going on? The Viewer lets this appear as an error. Is it one?

Attachments

Not run yet.usc (88.1 KB) - added by michelpons 10 years ago.
UniSim Design case file just before run
unisimdesign_071011_144527.log (60.8 KB) - added by michelpons 10 years ago.
Log file obtained with COLTT 1.08.05 MSI May 30, 2011
unisimdesign_090911_195010.log (57.0 KB) - added by michelpons 9 years ago.
Log file obtained with COLTT 1.08.5 Build July 17, 2011 modified 88 and 89 TRAC

Change History

Changed 10 years ago by michelpons

UniSim Design case file just before run

Changed 10 years ago by michelpons

Log file obtained with COLTT 1.08.05 MSI May 30, 2011

comment:1 Changed 9 years ago by michelpons

  • Status changed from new to closed
  • Resolution set to worksforme
  • Milestone set to 2.00

Using COLTT 1.08.5 Build July 17, 2011 with modifications regarding resolution of TRAC issues 88 and 89, the SetProp return is mentioned in the log (see attached) so the issue is resolved.

Changed 9 years ago by michelpons

Log file obtained with COLTT 1.08.5 Build July 17, 2011 modified 88 and 89 TRAC

Note: See TracTickets for help on using tickets.