Ticket #5 (assigned defect)

Opened 11 years ago

Last modified 9 years ago

Error message box from COFE not showing up instead COFE crashes

Reported by: michelpons Owned by: michaelhalloran
Priority: major Milestone:
Component: COLoggers Version: Development
Keywords: Cc:

Description

I am using a simple mixer Unit Operation made with the FORTRAN Unit Operation Wizard. When COLTT is not enabled on the FTNMixer Unit Operation, the calculation raises an exception for this UO and COFE displays an error message box as in the Screenshots.doc attachment.
If I am enabling COLTT v1.07 on the FTNMixer UO, COFE behaves the same as without COLTT enabled. Now with COLTT 1.08.02, COFE crashes at calculation time without displaying the error message box shown in Screenshots.doc.

I attach the log files obtained with COLTT v1.07 and v1.08.02. Fpr the FTNMixer the installatio file is too large for being attached on TRAC.

Michel

Attachments

cofe_090809_100900_v107.log (15.1 KB) - added by michelpons 11 years ago.
COLTT log file obtained with COLTT 1.07
Screenshots.zip (14.1 KB) - added by michelpons 11 years ago.
Screenshot of error message box in COFE (zipped Word doc)
cofe_090809_101153_v10802.log (12.4 KB) - added by michelpons 11 years ago.
COLTT log file obtained with COLTT 1.08.02
Unconnected.fsd (22.9 KB) - added by michelpons 11 years ago.
COFE document used as a starting point
cofe_103109_113458.log (18.7 KB) - added by michelpons 11 years ago.
Log file obtained with COLTT 1.08.3 Build Oct 27, 2009
Screenshots311009.zip (14.2 KB) - added by michelpons 11 years ago.
Zipped RTF file containing screenshot obtained with COLTT 1.08.03 Build Oct 27, 2009
cofe_110609_104256.log (18.1 KB) - added by michelpons 11 years ago.
Log file obtained with COLTT 1.08.4
Screenshots_1-08-05.rtf.zip (213.3 KB) - added by michelpons 9 years ago.
Screenshots with and wo COLTT enabled using 1.08.05 May 30, 2011
cofe_060611_082257.log (55.6 KB) - added by michelpons 9 years ago.
Log file obtained with COLTT 1.08.05 Build May 30, 2011
Unconnected.2.fsd (29.6 KB) - added by michelpons 9 years ago.
COFE 2.03 document used as starting point in scenario

Change History

Changed 11 years ago by michelpons

COLTT log file obtained with COLTT 1.07

Changed 11 years ago by michelpons

Screenshot of error message box in COFE (zipped Word doc)

Changed 11 years ago by michelpons

COLTT log file obtained with COLTT 1.08.02

Changed 11 years ago by michelpons

COFE document used as a starting point

comment:1 Changed 11 years ago by michelpons

The installation kit for the FTNMixer is available from the following URL: http://www.yousendit.com/download/YkxKK2VsSWhUWUR2Wmc9PQ

Availability is limited to seven days.

comment:2 Changed 11 years ago by michaelhalloran

  • Owner changed from Michael Halloran to michaelhalloran
  • Status changed from new to assigned

Michel,

I think it is highly likely that this issue is caused by a problem I fixed to do with the Error interfaces in the 1.08.3 development build. If so then I think it is fixed in the new build that Ahsan made today (19/10). I can't retest because the yousendit link for the FORTRAN mixer has expired. Can you retest it, or if you want to send the mixer again I can try.

comment:3 Changed 11 years ago by michaelhalloran

  • Status changed from assigned to closed
  • Resolution set to fixed

Confirmed as fixed in builds after 24/10/09.

comment:4 Changed 11 years ago by michelpons

  • Status changed from closed to reopened
  • Resolution fixed deleted

I have tested the case with COLTT 1.08.3 Build Oct 27, 2009. COFE does not crash anymore during calculation. I get now a \"Solve failed\" message box (see attached Screenshots311009 zipped file) that is pretty much the same as the one obtained without COLTT enabled on the FTNMixer. However, without COLTT enabled, I get in the message box the full message displayed by the FTNMixer and appearing in the log file attached, i.e. CapeUnknown error: value not set [Error code = 0], while I get some garbage when COLTT 1.08.3 is enabled. So the issue is partially fixed to my understanding.

Changed 11 years ago by michelpons

Log file obtained with COLTT 1.08.3 Build Oct 27, 2009

Changed 11 years ago by michelpons

Zipped RTF file containing screenshot obtained with COLTT 1.08.03 Build Oct 27, 2009

comment:5 Changed 11 years ago by michaelhalloran

  • Status changed from reopened to assigned

Michel,

I think the problem is with the FTNMixer. When I run the example I get a different message to yours:

Unit <COLaNMixer_1> : Name: CapeUnknown error: value not set [Error code = 0]/f]

I think maybe the mixer is not handling BSTR string types properly and something about using COLTT makes it apparent. COLTT is not doing anything to either truncate or modify the string returned from the call to get_name.

The other thing I don't understand is why is FTNMixer returning the description when the call made is get_Name? Surely the response to get_Name ought to be just ECapeUnknownHR? Not CapeUnknown error: value not set [Error code = 0]/f]

Can you forward the source code for the mixer?

comment:6 Changed 11 years ago by michelpons

The source code of the FTNMixer has been deposited at http://download.yousendit.com/YkxJZHl1Z2pVVG5IRGc9PQ today

comment:7 Changed 11 years ago by michelpons

  • Milestone set to Refactoring

comment:8 Changed 11 years ago by michelpons

  • Version changed from 1.08.2 to 1.08.4

I have re-tested the case with COLTT 1.08.4: the defect remains. I have attached the corresponding log file (cofe_110609_104256.log).

Changed 11 years ago by michelpons

Log file obtained with COLTT 1.08.4

comment:9 Changed 9 years ago by michelpons

  • Version changed from 1.08.4 to Development

I have retested this issue using COLTT 1.08.05 Build May 30, 2011. I used COFE 2.03, i.e. the latest COFE version available. I observe that COFE does not crash when COLTT is enabled on the FTNMixer and encounters an error in Calculate. Still the error message is slightly different if COLTT is used or not. Don't know if this shows anything to be concerned of though. I attach the log obtained as well as the screenshots obtained in both cases. You should be able to rerun this one on your side since you have the FTNMixer installer.

Changed 9 years ago by michelpons

Screenshots with and wo COLTT enabled using 1.08.05 May 30, 2011

Changed 9 years ago by michelpons

Log file obtained with COLTT 1.08.05 Build May 30, 2011

Changed 9 years ago by michelpons

COFE 2.03 document used as starting point in scenario

comment:10 Changed 9 years ago by michelpons

  • Milestone changed from Refactoring to 1.10
Note: See TracTickets for help on using tickets.