Ticket #28 (closed defect: worksforme)

Opened 11 years ago

Last modified 9 years ago

08-136 COUSCOUS UO in PRO/II 8.2

Reported by: michelpons Owned by: Michael Halloran
Priority: major Milestone: 2.0 No dependency/Viewer/New installer
Component: COLoggers Version: 1.08.4
Keywords: Cc: michaelhalloran

Description

I used COLTT 1.08.3 Build Oct 27, 2009 on a combination of PMC-PME that was used to document a defect in 2008 where it was impossible to get a log with COLTT 1.06. Logging is now possible with COLTT latest version.

The calculation does not run properly in PRO/II. This may be related to the fact that it is PRO/II 8.2 that is used here. I get an error message from PRO/II saying:

2 error(s), 0 warning(s), and 0 message(s) detected:

* error * Unit 1, 'co1' - the cape-open data file 'c:
docume~1
michel~1
locals~1
temp
ssi82
unconnected_co1.Dat' was not found.
* error * Unit 1, 'co1' - not all material ports are connected.

The COLTT log file (proii_103109_232827.log) is showing that disconnect calls on ports are raising exceptions:

Port <Outlet> : Return from get_portType - Succeeded
Port <Inlet 1> : Call to Disconnect
Port <Inlet 1> : Error returned from Disconnect - 0x80040501
Port <Inlet 2> : Call to Disconnect
Port <Inlet 2> : Error returned from Disconnect - 0x80040501
Port <Outlet> : Call to Disconnect
Port <Outlet> : Error returned from Disconnect - 0x80040501

PRO/II seems to choose not to investigate further the exception since no attempt seems to be made to get information on the error. However I am puzzled by the fact that COLTT does not try either. I thought that, whatever the PME behaviour regarding error handling, COLTT logger was supposed to call ECapeUser and so on in order to get at least a better description of the error. It does not seem to happen there so the log is not sufficiently informative.

Attachments

proii_103109_232827.log (32.0 KB) - added by michelpons 11 years ago.
Log file obtained with COLTT 1.08.3 build Oct 27, 2009
proii_090511_173557.log (635 bytes) - added by michelpons 9 years ago.
Log file obtained with COLTT 1.08.5 Build July 17, 2011

Change History

Changed 11 years ago by michelpons

Log file obtained with COLTT 1.08.3 build Oct 27, 2009

comment:1 Changed 11 years ago by michaelhalloran

  • Owner changed from Michael Halloran to ahsanakhtar
  • Status changed from new to assigned
  • Type changed from enhancement to defect

Ahsan,

Can you fix this problem? Michel is correct that the PortST logger is not calling MakeErrorLog for most calls, when it should do in the case of an error. Could you check the other loggers as well? In general when a method fails and returns an error (i.e. it's not an exception) the code should call MakeErrorLog to report the details of the CAPE-OPEN error.

comment:2 Changed 11 years ago by michelpons

  • Version changed from 1.08.3 to 1.08.4

I have re-tested this issue with COLTT 1.08.4 and the problem is still there.

comment:3 Changed 10 years ago by anonymous

  • Owner changed from ahsanakhtar to Michael Halloran

comment:4 Changed 9 years ago by michelpons

  • Status changed from assigned to closed
  • Resolution set to worksforme

From what I gather from my archives, the initila issue logged on April 29, 2009 mentioned that the message written in the log was unclear. It said then that \"Call to ICapeUnit not supported in COLTT\". With COLTT 1.08.5 Build July 17, 2011, it now says \" Error - Mixer does not support the CAPE-OPEN 1.0 or 1.1 interfaces that can be logged by COLTT

Simulation will continue without logging for Mixer\". This is due to the call to ICapeUnit made by PRO/II 8.2 before any call to Initialize. The current message is clear enough and I think this issue may be closed.

Changed 9 years ago by michelpons

Log file obtained with COLTT 1.08.5 Build July 17, 2011

comment:5 Changed 9 years ago by michelpons

  • Milestone set to 1.08.05
Note: See TracTickets for help on using tickets.