Ticket #198 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

ECapeThrmPropertyNotAvailable not considered as a CAPE-OPEN error

Reported by: michelpons Owned by: michelpons
Priority: major Milestone: 2.3
Component: COLoggers Version: 2.3
Keywords: ECapeThrmPropertyNotAvailable Cc: michaelhalloran

Description

I have a PME returning 0x8004051a to a CalcsinglePhaseProp call:
PropertyPackage <WaterEthanol> : Call to CalcSinglePhaseProp

CalcSinglePhaseProp takes input Arguments:

Property Phase
POH Liquid

MaterialObject <1> : Call to GetPresentPhases

GetPresentPhases returns:

Phase Status
Liquid CAPE_ATEQUILIBRIUM

MaterialObject <1> : Return from GetPresentPhases - Succeeded
MaterialObject <1> : Call to GetTPFraction

GetTPFraction takes Input Argument:

The Phase: Liquid

GetTPFraction returns:

Phase Temperature Pressure Composition

Liquid 298.15 101325 0.9

0.1

MaterialObject <1> : Return from GetTPFraction - Succeeded
COLTT <WaterEthanol> : Windows error code returned is: 0x8004051a - not known
COLTT <WaterEthanol> : No error information available, call to GetErrorInfo returned: 0x1
PropertyPackage <WaterEthanol> : Error returned from CalcSinglePhaseProp - 0x8004051a
PropertyPackage <WaterEthanol> : Call to get_description
PropertyPackage <WaterEthanol> : Description: pO

v CALUPP failed to calculate properties that may be caused by missing parameters or other reasons, please see history file.
PropertyPackage <WaterEthanol> : Return from get_description – Succeeded

This is read by COLTT as a Windows error and not as a CAPE-OPEN error. It should be read as a CAPE-OPEN error.

Change History

comment:1 Changed 5 years ago by michaelhalloran

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in builds of COLTT 2.3 after April 8th 2016 - fixed in commit #316

Note: See TracTickets for help on using tickets.