Ticket #142 (closed defect: fixed)

Opened 8 years ago

Last modified 8 years ago

Calls wrongly attributed to COLTT

Reported by: michelpons Owned by: michaelhalloran
Priority: major Milestone: 2.1
Component: COLoggers Version: Development
Keywords: Calculate Cc: michaelhalloran

Description

I am using PRO/II 9.2 alpha and I am starting from a case file where the CPP Ideal Thermo PPM and its PP nC6nC8 are plugged in. Then I am inserting the CPP MixerSplitter example UO, connected its two inlets and one outlet.

Then I am running the case, saving and exiting. This gives the attached log file. I am looking at the sequence of calls logged at the beginning of the Calculate call:

COLTT <Anonymous> : Call to GetOverallProp

GetOverallProp Takes Input arguments:

Property Basis
pressure UNDEFINED

GetOverallProp Returns:

Property Basis ValueReturned
pressure UNDEFINED 100000

COLTT <Anonymous> : Return from GetOverallProp - Succeeded
COLTT <Anonymous> : Call to GetOverallProp

GetOverallProp Takes Input arguments:

Property Basis
totalFlow mole

GetOverallProp Returns:

Property Basis ValueReturned
totalFlow mole 1.25998

COLTT <Anonymous> : Return from GetOverallProp - Succeeded
COLTT <Anonymous> : Call to GetOverallProp

GetOverallProp Takes Input arguments:

Property Basis
fraction mole

GetOverallProp Returns:

Property Basis ValueReturned
fraction mole 0.3

0.7

COLTT <Anonymous> : Return from GetOverallProp - Succeeded
COLTT <Anonymous> : Call to CreateMaterial
COLTT <Anonymous> : Return from CreateMaterial - Succeeded
COLTT Reference count for MO logger is 2
MaterialObject <Anonymous> : Call to CopyFromMaterial

It says that COLTT retrieves pressure, totalflow and composition. Well my reading of the CPP MixerSplitter source code tells me it is the Unit Operation which does that.

00195 first let us make sure we are in a valid state
00196 if (valStatus==CAPE_INVALID)
00197 {SetError(L\"Unit is not valid\",L\"ICapeUnit\",L\"Calculate\");
00198 return ECapeUnknownHR;
00199 }
00200 if (valStatus==CAPE_NOT_VALIDATED)
00201 {SetError(L\"Unit has not been validated\",L\"ICapeUnit\",L\"Calculate\");
00202 return ECapeUnknownHR;
00203 }
00204 ATLASSERT(valStatus==CAPE_VALID);
00205
init variables
00206 componentFlows.resize(nCompounds);
00207 for (j=0;j<nCompounds;j++) componentFlows[j]=0;
00208 totalFlow=0;
00209 enthalpy=0;
00210 pressure=0;
00211 loop over the connected feed ports, get the minimum pressure and the total component and enthalpy flows
00212 for (i=0;i<2;i++)
00213 {port=(MaterialPortObject *)portCollection->items[i];
00214 if (port->IsConnected())
00215 {
get the pressure
00216 material=port->GetMaterial();
00217 if (!material.GetOverallProperty(L\"pressure\",NULL,value,error))
00218 {SetError(error.c_str(),L\"ICapeUnit\",L\"Calculate\");
00219 return ECapeUnknownHR;
00220 }
00221 check count
00222 if (value.GetCount()!=1)
00223 {SetError(L\"Invalid values for pressure from material object: scalar expected\",L\"ICapeUnit\",L\"Calculate\");
00224 return ECapeUnknownHR;
00225 }
00226
use minimum pressure
00227 d=value.GetDoubleAt(0);

00228 if ((pressure==0)
(d<pressure)) pressure=d;

00229 get total flow
00230 if (!material.GetOverallProperty(L\"totalFlow\",L\"mole\",value,error))
00231 {SetError(error.c_str(),L\"ICapeUnit\",L\"Calculate\");
00232 return ECapeUnknownHR;
00233 }

Attachments

Unconnected.prz (27.6 KB) - added by michelpons 8 years ago.
Case file from which to begin from in PRO/II 9.2
proii_081712_095643.log (129.3 KB) - added by michelpons 8 years ago.
Log file obtained with COLTT 2.1 Build Aug 5, 2012

Change History

Changed 8 years ago by michelpons

Case file from which to begin from in PRO/II 9.2

Changed 8 years ago by michelpons

Log file obtained with COLTT 2.1 Build Aug 5, 2012

comment:1 Changed 8 years ago by michaelhalloran

  • Owner changed from Michael Halloran to michaelhalloran
  • Status changed from new to assigned

I think this is a duplicate of 141: it's the same problem but happening within Calculate rather than Validate.

comment:2 Changed 8 years ago by michaelhalloran

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixed with fix to #129.

Note: See TracTickets for help on using tickets.