Ticket #1 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

09-021 COLTT 1.08.2 fails with Aspen Hysys and PPDS

Reported by: michaelhalloran Owned by: michaelhalloran
Priority: critical Milestone: Refactoring
Component: COLoggers Version: 1.08.2
Keywords: Cc:

Description

This morning I had a remote session organized with Andy Johns of TUV NEL Ltd about a test of their PPDS Thermo server implementing Thermo 1.1 in Aspen Hysys v7.1.


During a run based on a case provided by one of TUV NEL clients (ABB I guess), I observed error messages sent by PPDS to Aspen Hysys about stream composition appearing as null. PPDS is equipped with its own logging facility but it is far from complete: the SetPresentPhases is not logged for example. So I moved to COLTT.


With COLTT 1.07 I was able to give evidence to Andy that PPDS was at fault while setting present phases for both vapor and liquid when the phase fraction for liquid was something like 10 to the minus 16 and while the liquid phase composition was set by PPDS to zero for all compounds. Then Aspen Hysys had the right to request the calculation of liquid phase properties that PPDS was unable to provide since it raises an exception when finding that the composition was null in the MO.


That proves that COLTT is working well.


The only problem I got was that Aspen Hysys is crashing when exiting (see ScreenshotsCOLTTv107.doc). No big deal except it means the PPDS license is not released.


So I moved to COLTT v1.08.02 with the hope of having it doing better on that. Well it is a complete failure: Aspen Hysys simply crashes when opening the case.


I will send you the logs obtained with 1.07 (hysys_090409_115121_v107.log) and 1.08.02 (hysys_090409_114804_v10802.log) as accompanying material in a zipped archive. The issue is numbered 09-021.

Attachments

hysys_090409_114804_v10802.log (881 bytes) - added by michaelhalloran 11 years ago.
Log from COLTT 1.08.2
hysys_090409_115121_v107.zip (31.3 KB) - added by michaelhalloran 11 years ago.
Log from COLTT 1.07
hysys_102209_153649.zip (35.8 KB) - added by michelpons 11 years ago.
Log file obtained with COLTT 1.08.03
ScreenshotsCOLTTv10803.zip (37.6 KB) - added by michelpons 11 years ago.
Screenshots obtained with 1.08.03

Change History

Changed 11 years ago by michaelhalloran

Log from COLTT 1.08.2

Changed 11 years ago by michaelhalloran

Log from COLTT 1.07

comment:1 Changed 11 years ago by michaelhalloran

  • Version set to 1.08.2
  • Component changed from component1 to COLoggers

Changed 11 years ago by michelpons

Log file obtained with COLTT 1.08.03

Changed 11 years ago by michelpons

Screenshots obtained with 1.08.03

comment:2 Changed 11 years ago by michelpons

Using COLTT 1.08.03 (Built Oct 19, 09) I have retested the combination of PPDS PPM and Aspen Hysys. The behaviour I observe when COLTT 1.08.03 is enabled on PPDS PPM is now similar to the one observed with COLTT 1.07: a log is obtained and Aspen Hysys crashes when exiting.

I have attached the screenshots obtained as well as the log file obtained.

I recommend closing this issue since the discrepancy between 1.07 and 1.08.03 is resolved. A new issue should be created about Aspen Hysys crashing.

comment:3 Changed 11 years ago by michaelhalloran

  • Owner changed from SHMA to michaelhalloran
  • Status changed from new to assigned

comment:4 Changed 11 years ago by michelpons

  • Status changed from assigned to closed
  • Resolution set to fixed

I have rerun the case with COLTT 1.08.3 Build Oct 27, 2009. I confirm that now the behaviour observed is the same with COLTT 1.08 and COLTT 1.07. I proceed to close this ticket that was related to the difference of behaviour between v1.07 and v1.08. I will open a new ticket regarding the Aspen Hysys crash upon exiting Aspen Hysys.

comment:5 Changed 11 years ago by michelpons

  • Milestone set to Refactoring
Note: See TracTickets for help on using tickets.