Ticket #29 (closed defect: fixed)

Opened 5 weeks ago

Last modified 4 weeks ago

Public property should be private property

Reported by: jasper Owned by:
Priority: critical Milestone: 1.1 extension maintenance
Component: TLB/PIA x64 merge module Version: 2.1.2
Keywords: Cc:

Description

The problem is that the directory names
CAPEOPENDIRECTORY.6087DC79_F9E7_4A90_BF9C_5DC775355161 and
CAPEOPENDIRECTORY.FF607CD6_DDED_4C72_9407_AF18309AF5BC are upper case
making them public properties. I assume those are coming from the
TLB merge module? We need to change them to private properties with
mixed case. By default, these values are set to the c:\program files
area in the front end because the installer starts out with a
per-machine installation since no ALLUSERS/MSIINSTALLPERUSER setting
has been set. Adding these properties will not fix the problem
because you will have the reverse problem when doing a per-machine
install. The content will be installed in the wrong folder, although
permissions will not be an issue.

Public properties are passed from the front end to the back end on
the command line and thus are not changed in the back end.

Change History

comment:1 Changed 5 weeks ago by jasper

As a result of the above, installers that have a dialog for selection of all users vs current user, may fail at run time for a current user installation, as the merge modules did not "get the message" in time and attempt to install to an all users installation location without the proper rights.

comment:2 Changed 5 weeks ago by michelpons

  • Milestone set to 1.1 extension maintenance

comment:3 Changed 4 weeks ago by jasper

fixed in revision 127

comment:4 Changed 4 weeks ago by michelpons

Was checked as working by Jasper in distribution obtained from source of commit 144.

comment:5 Changed 4 weeks ago by michelpons

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.