Ticket #45 (closed enhancement: wontfix)

Opened 18 months ago

Last modified 17 months ago

cobiaRegister /u reports ok for PMCs that are not registered

Reported by: jasper Owned by: jasper
Priority: major Milestone: Maintenance of Phase II
Component: Registrar Version: 1.2.0.1
Keywords: Cc:

Description

This is not a bug, it was designed this way. After /u, it reports ok if the PMC is not registered.

But perhaps this is not the best design - should we raise "not found" in this case?

Change History

comment:1 Changed 18 months ago by jasper

  • Status changed from new to closed
  • Resolution set to wontfix
  • when unregistering a DLL, there could be multiple PMCs, so "Not found" is not straight forward unless none of them are found
  • when unregistering a PMC COBIA actually unregisters a particular service of the PMC, e.g. native x86 or native x64. Only after removing the last service, the entire PMC registration is removed
  • unregistration can also be invoked for a particular CLSID. In this case querying whether it exists can be done separately using cobiaRegister /i.

Considering all of this, a "not found" is perhaps confusing as well.

The issue is closed until a business case arises.

comment:2 Changed 17 months ago by michelpons

  • Milestone set to Maintenance of Phase II
Note: See TracTickets for help on using tickets.