Ticket #47 (assigned defect)

Opened 11 years ago

Last modified 9 years ago

Return from Calculate missing

Reported by: michelpons Owned by: michaelhalloran
Priority: major Milestone:
Component: Viewer Version: Development
Keywords: Cc: michaelhalloran

Description

I am using a gO:CAPE-OPEN UO (gPROMS version 3.2.0) in Aspen Plus 7.1 CP1. The process model is one of methanol synthesis with a detailed reactor model in the gO:CAPE-OPEN UO. The run gives an error in this Aspen Plus history file and consequently COLTT is enabled on go:CAPE-OPEN.

In the attached log file, there is a call to Calculate logged but then, instead of having a return from Calculate, I see:

MaterialObject <Anonymous> : Call to GetProp

Property Phase--- Basis--- Calc---- Compounds Values returned
fraction overall mole (null) METHANOL 0.000748225

HYDROGEN 0.683844170
CO 0.315407605

MaterialObject <Anonymous> : Return from GetProp - Succeeded
Unit <B2> : Call to ICapeIdentification.get_ComponentName
Unit <B2> : Return from ICapeIdentification.get_ComponentName - Succeeded
Unit <B2> : Call to Unidentified Interface: {1C733A30-2A1C-11CE-ADE5-00AA0044773D}
Unit <B2> : Call to get_code
Unit <B2> : Code: 0
Unit <B2> : Return from get_code - Succeeded
Unit <B2> : Call to get_description
Unit <B2> : Description: no error
Unit <B2> : Return from get_description - Succeeded
Unit <B2> : Call to get_moreInfo
Unit <B2> : More Info:
Unit <B2> : Return from get_moreInfo - Succeeded
Unit <B2> : Call to get_interfaceName
Unit <B2> : Interface Name:
Unit <B2> : Return from get_interfaceName - Succeeded
Unit <B2> : Call to Validate

Checking validation status before the call...

Unit <B2> : Call to get_ValStatus
Unit <B2> : Return from get_ValStatus - CAPE_VALID
Unit <B2> : Return from Validate - Succeeded, isValid=true

Since there is a call to Validate, it means Calculate has finished. However there is no line logging the return from Calculate. When using Aspen Plus 7.1CP2 the error is not there and a CalcEquilibrium call for a PH flash is logged just before exiting Calculate and just after the return from GetProp logged here.

Attachments

apmain_113009_164827.zip (21.0 KB) - added by michelpons 11 years ago.
Zipped log file obtained
apmain_060211_135935.zip (30.0 KB) - added by michelpons 9 years ago.
Zipped log file obtained with May 30, 2011 build
apmain_030812_205342.zip (32.7 KB) - added by michelpons 9 years ago.
Zipped log file obtained with COLTT 2.1 Development Build
History_08-03-2012.txt (15.2 KB) - added by michelpons 9 years ago.
Aspen Plus history file obtained with COLTT v2.1 Development Build
Myunconnected71CP1.bkp (13.6 KB) - added by michelpons 9 years ago.
Aspen Plus 7.1 CP1 case file used in the scenario

Change History

Changed 11 years ago by michelpons

Zipped log file obtained

comment:1 Changed 11 years ago by michaelhalloran

  • Status changed from new to closed
  • Resolution set to Not fixable - PME Issue

COLLT does log the return from Calculate. I suspect that there has been an Aspen Plus exception during Calculate. The Aspen Plus exception handler does a longjmp or equivalent which means that the return from Calculate would not have gone through COLTT. This could be confirmed with an Aspen Plus engine log. I don't think this can be fixed in COLTT.

comment:2 Changed 9 years ago by michelpons

  • Status changed from closed to reopened
  • Resolution Not fixable - PME Issue deleted
  • Version changed from 1.08.4 to Development
  • Component changed from COLoggers to Viewer

I have re-run the scenario with the COLTT Build dated May 30, 2011. The same issue remains. While I understand it may be a PME issue, there is a need to address the fact that now viewing the log file goes through the Viewer. And the Viewer has difficulties figuring how to present the log. There is no warning about difficulties to read the file. The file seems to be perfect from a Viewer point of view even if it ends with the first Calculate as the last CAPE-OPEN call and everything after is within that call. Still there is one Calculate return missing at least in the file. This ought to be detected by the Viewer and made noticeable to the end-user. I attach to this re-opened issue the latest log file obtained.

Changed 9 years ago by michelpons

Zipped log file obtained with May 30, 2011 build

comment:3 Changed 9 years ago by anonymous

  • Owner changed from Michael Halloran to michaelhalloran
  • Status changed from reopened to assigned

comment:4 Changed 9 years ago by michelpons

  • Milestone set to 1.10

comment:5 Changed 9 years ago by michelpons

I have rerun the case using the COLTT 2.1 Development Build. I observe the same situation as with previous COLTT versions. The Aspen Plus history file records that the calculation of the CAPE-OPEN UO block does not succeed and reports the information collected from the CAPE-OPEN error handling calls. Still there is no return from Calculate and the log jumps immediately to a Validate call after the first instance of Calculate. This makes reading the log file difficult because the Call to Calculate appears as the last log entry and needs to be expanded in order to see the second call to Calculate and the subsequent calls.
I am adding the log file obtained as well as the history file out of Aspen Plus. The case requires both gPROMS and Aspen Plus to be run.

Changed 9 years ago by michelpons

Zipped log file obtained with COLTT 2.1 Development Build

Changed 9 years ago by michelpons

Aspen Plus history file obtained with COLTT v2.1 Development Build

Changed 9 years ago by michelpons

Aspen Plus 7.1 CP1 case file used in the scenario

Note: See TracTickets for help on using tickets.