Ticket #36 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

09-007 Anonymous versus real name

Reported by: michelpons Owned by: Michael Halloran
Priority: minor Milestone: Refactoring
Component: COLoggers Version: 1.08.2
Keywords: Cc: michaelhalloran

Description

De: Michael Halloran [michaeljhalloran@…]
Envoyé: Saturday, April 25, 2009 7:40 PM
À: Michel Pons
Cc: Ahsan Akhtar
Objet: Re: Simulis Thermodynamics in Aspen Hysys 2004
Michel,

You'll notice that the calls which use anonymous as the name are all on the ICapeUtilities Interface which is a separate logger in 1.08 after the refactoring. The problem is that this logger hasn't been told that the name of the unit has changed.

Ahsan, there needs to be a mechanism to pass the name of the owning PMC to all aggregated loggers when the name is changed. It should be similar to SetLoggedComponent but it only needs to pass name. It needs to be called from put_PMCName. Could you investigate?

Regards
Michael
===========================================================
De: Michel Pons [technologyofficer@…]
Envoyé: Wednesday, April 15, 2009 10:28 AM
À: 'Ahsan Akhtar'
Cc: 'michaeljhalloran@…'
Objet: FW: Simulis Thermodynamics in Aspen Hysys 2004

Pièces jointes: hysys_041009_170955.log

Ahsan,

I was not able to pinpoint which of the « old » issues this was related to. So please consider this as issue 09-007 till one knows better.

Best regards

Michel
===============================================================
De: Michel Pons [technologyofficer@…]
Envoyé: Friday, April 10, 2009 5:54 PM
À: 'Michael Halloran'
Cc: 'Ahsan Akhtar'
Objet: RE: Simulis Thermodynamics in Aspen Hysys 2004

Pièces jointes: hysys_041009_170955.log

Michael,

Please find attached a log of a MatLabUO in Aspen Hysys v7.1 as logged with COLTT v1.08.02.

I don’t see a difference between having MatLabUO logged and not logged. I get the same kind of errors displayed by Aspen Hysys.

Still I am a bit bewildered by the fact that once Aspen Hysys has put CO-100 as component name,

Unit <Anonymous> : Call to put_ComponentName
Unit put_ComponentName puts: CO-100
Unit <CO-100> : Return from put_ComponentName - No Error

I still get now and then <Anonymous> to be used as name for the UO:

Unit <Anonymous> : Call to get_parameters

Unit <Anonymous> : Return from get_parameters - No Error

Unit <Anonymous> : Call to Edit
Unit <Anonymous> : Return from Edit - No Error

Amidst numerous entries using <CO-100> as the Unit name. I think this is an old issue though.

Best regards

Michel

Attachments

hysys_041009_170955.log (8.3 KB) - added by michelpons 11 years ago.
Log file obtained with COLTT 1.08.2 and Matlab UO
hysys_110409_175905_1082.log (7.1 KB) - added by michelpons 11 years ago.
Log file obtained with COLTT 1.08.2 enabled on Scilab UO
hysys_110409_172356_1083.log (8.6 KB) - added by michelpons 11 years ago.
Log file obtained with COLTT 1.08.3 enabled on Scilab UO

Change History

Changed 11 years ago by michelpons

Log file obtained with COLTT 1.08.2 and Matlab UO

comment:1 Changed 11 years ago by michelpons

  • Status changed from new to closed
  • Resolution set to fixed

I have checked this case with COLTT 1.08.3 Build Oct 27, 2009. However I have not been able to rerun the case with the Matlab UO since I have no license anymore for Matlab. I have set up the case with Scilab. I have checked that with COLTT 1.08.2 enabled on the Scilab UO from AmsterCHEM, the name of the UO is not always mentioned in the log (see hysys_110409_175905_1082.log):

Unit <Anonymous> : Call to Edit
Unit <Anonymous> : Return from Edit - No Error
Unit <CO-100> : Call to Validate

Starting validation state is CAPE_VALID

Unit <CO-100> : Return from Validate - No Error, isValid=false

Validation state is now CAPE_INVALID
message returned was: Feed port \"Feed 1\" is not connected

Unit <CO-100> : Call to get_ports

while with COLTT 1.08.3, the actual name of the UO is always mentioned (see hysys_110409_172356_1083.log):

Unit <CO-100> : Call to Edit
Unit <CO-100> : Return from Edit - Succeeded
Unit <CO-100> : Call to Validate

Checking validation status before the call...

Unit <CO-100> : Call to get_ValStatus
Unit <CO-100> : Return from get_ValStatus - CAPE_VALID
Unit <CO-100> : Return from Validate - Succeeded, isValid=false

So the defect has been resolved somehow in between 1.08 from April and 1.08.3. I will close the defect accordingly.

Changed 11 years ago by michelpons

Log file obtained with COLTT 1.08.2 enabled on Scilab UO

Changed 11 years ago by michelpons

Log file obtained with COLTT 1.08.3 enabled on Scilab UO

Note: See TracTickets for help on using tickets.