Ticket #32 (closed defect: fixed)

Opened 11 years ago

Last modified 8 years ago

SetFontCellColor error

Reported by: michelpons Owned by: Michael Halloran
Priority: major Milestone: 2.1
Component: COLoggers Version: Development
Keywords: Cc: michaelhalloran

Description

With COLTT 1.08.3 Build Oct 27, 2009 enabled on GLCC UO in Aspen Hysys, I get at first the same error messages as with GLCC UO alone (related to array parameters) but then I have a stream of error messages about SetFontCellColor error that I don't get with GLCC alone. I obtain a log file (hysys_110309_150132.log attached as zip) but the behavior is wrong. Attached is also screenshots of the scenario played (MyScreenshots031109.zip) in a RTF file.

Attachments

hysys_110309_150132.zip (19.3 KB) - added by michelpons 11 years ago.
Zipped log file obtained with COLTT 1.08.3 Build Oct 27, 2009
MyScreenshots031109.zip (183.8 KB) - added by michelpons 11 years ago.
Scenario through screen copies
hysys_063010_141022.zip (19.3 KB) - added by michelpons 10 years ago.
Zipped log file obtained with 1.08.4
hysys_060111_205246.zip (28.8 KB) - added by michelpons 9 years ago.
Zipped log file obtained with COLTT build May 30, 2011
hysys_030812_192745.zip (40.6 KB) - added by michelpons 9 years ago.
Zipped log file obtained with COLTT 2.1 Development build

Change History

Changed 11 years ago by michelpons

Zipped log file obtained with COLTT 1.08.3 Build Oct 27, 2009

Changed 11 years ago by michelpons

Scenario through screen copies

comment:1 Changed 10 years ago by michelpons

  • Version changed from 1.08.3 to 1.08.4

I have rerun the case using 1.08.4 and the issue is still there: a dozen or so of error message boxes appear \"SetFontCellColor\" when the GLCC UO is logged. They don't appear when the scenario is run without COLTT enabled on GLCC UO. I have attached the log file obtained.

Changed 10 years ago by michelpons

Zipped log file obtained with 1.08.4

comment:2 Changed 9 years ago by michelpons

  • Version changed from 1.08.4 to Development

Using COLTT 1.08.05 Build of May 30, 2011, I have replayed the scenario involving Aspen Hysys and the GLCC UO. With COLTT enabled on the GLCC UO, there are extra error messages compared to the case where COLTT is not enabled on the GLCC UO: these error messages are about a SetFontCellColor error. The log attached obtained today loads well in the Viewer.

Changed 9 years ago by michelpons

Zipped log file obtained with COLTT build May 30, 2011

comment:3 Changed 9 years ago by michelpons

  • Milestone set to 1.09

comment:4 Changed 9 years ago by michelpons

I have used COLTT 2.1 Development Build to test case #32. I see the same SetFontCellColor? error messages as with previous versions of COLTT. See the attached log that does not tell much about what happens.

Changed 9 years ago by michelpons

Zipped log file obtained with COLTT 2.1 Development build

comment:5 Changed 8 years ago by michaelhalloran

  • Status changed from new to closed
  • Resolution set to fixed

The SetFontCell error is fixed now that COLTT checks the type of returned variants before using them. The Hysys error remain and I suspect they are reporting the same problem but not very clearly. Fix will be available in next build of the 2.1 release.

Note: See TracTickets for help on using tickets.