Ticket #174 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

ProSim Plus crashes with error interfaces automatic calls

Reported by: michelpons Owned by: Michael Halloran
Priority: major Milestone: 2.2
Component: COLoggers Version: Development
Keywords: Errors Cc: michaelhalloran

Description

I am using ProSim Plus 3.3.13.0 together with Aspen Properties v8.0. It is a simple flash but on a mixture containing ions. I am enabling COLTT on Aspen Properties Thermo System and I am running the flowsheet made of a single unit operation, a TP flash. When the box is ticked about error interfaces automatically called when errors are raised, ProSim Plus crashes. When I am simply enabling COLTT and no other options, the run goes to its end nicely. I am using COLTT 2.1 Build 280. My guess is that the description of the last error is a bit too long for COLTT to handle it, but it is just a guess.

Attachments

prosimplus_102013_221355.log (41.9 KB) - added by michelpons 9 years ago.
Log file with error interfaces automatically called
prosimplus_102013_221748.log (100.9 KB) - added by michelpons 9 years ago.
Log file without error interfaces automatically called
Maarten_case.bkp (21.8 KB) - added by michelpons 9 years ago.
Aspen Plus bkp file to generate Property Package
Test.pmp3 (55.4 KB) - added by michelpons 9 years ago.
ProSim 3.3 case file using Aspen Properties Property Package
prosimplus_102713_150031.log (148.0 KB) - added by michelpons 9 years ago.
Log file obtained with commit 284

Change History

Changed 9 years ago by michelpons

Log file with error interfaces automatically called

Changed 9 years ago by michelpons

Log file without error interfaces automatically called

Changed 9 years ago by michelpons

Aspen Plus bkp file to generate Property Package

Changed 9 years ago by michelpons

ProSim 3.3 case file using Aspen Properties Property Package

comment:1 Changed 9 years ago by michaelhalloran

  • Status changed from new to closed
  • Resolution set to fixed

Fixed with Commit 284. Tested without reproducing the long string found in this example. Please retest this case to check it's OK now.

comment:2 Changed 9 years ago by michelpons

I confirm that the issue is resolved with commit 284. See attached log made with ProSim Plus using an Aspen Properties Property Package. Enabling logging of error interfaces lets the calculation go to its end with the new build.

Changed 9 years ago by michelpons

Log file obtained with commit 284

Note: See TracTickets for help on using tickets.