Ticket #161 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

COFE crash

Reported by: michelpons Owned by: michaelhalloran
Priority: major Milestone: 2.2
Component: COLoggers Version: Development
Keywords: crash Cc:

Description

I am using COLTT 2.1 Build 263. I am running COFE 2.6.0.2 with the VB6 Ideal ThermoSystem. COLTT is enabled on VB6 Thermo System with error interfaces calls activated as well as reference count logging activated. I open COFE, select the VB6 Thermo System as Property Package and then COFE stops: it displays an APPCRASH. See attached the file detailing the problem. The log file (also attached) shows IPersistStreamInit as the last call. I am running COFE in Windows 7.

Attachments

Crash.txt (803 bytes) - added by michelpons 9 years ago.
Details of the crash
cofe_091013_122751.log (998 bytes) - added by michelpons 9 years ago.
Log file obtained with COLTT 2.1.263

Change History

Changed 9 years ago by michelpons

Details of the crash

Changed 9 years ago by michelpons

Log file obtained with COLTT 2.1.263

comment:1 Changed 9 years ago by michelpons

  • Version changed from 2.1 to Development

COFE does not crash with COLTT 2.1 official release, aka Build 239. Error interface calls and reference counting not enabled. Mind that the call to IPersistStreamInit on which Build 263 seems to crash, leads to an exception:

ThermoSystem <Anonymous> : Error returned from QueryInterface - 0x80004002

as reported in the log file produced with Build 239.

comment:2 Changed 9 years ago by michaelhalloran

  • Status changed from new to closed
  • Resolution set to fixed

Fixed with commit 272. Caused by a build error that created a mismatch in interfaces used by the error logging.

Note: See TracTickets for help on using tickets.