Ticket #11 (closed defect: fixed)

Opened 11 years ago

Last modified 9 years ago

09-001 richtx32 ocx file not properly registered at installation

Reported by: michelpons Owned by: ahsanakhtar
Priority: major Milestone: Refactoring
Component: COLoggingController Version: 1.08.3
Keywords: Cc: ahsanakhtar; michaelhalloran

Description

I have installed COLTT 1.08.03 in a machine with UniSim Design and Simulis Thermodynamics. When launching COLTT controller I got a debug assertion failed message. UniSim Design being very close to Aspen Hysys, I figured the issue was with richtx32.ocx not properly registered at installation. Indeed using regsvr32 on richtx32.ocx resolved the issue that was supposed to have been resolved in 1.08.03.

Change History

comment:1 Changed 11 years ago by michaelhalloran

  • Owner changed from Michael Halloran to ahsanakhtar
  • Status changed from new to assigned

comment:2 Changed 11 years ago by michelpons

I have installed COLTT 1.08.03 (release of Oct 19, 2009) in a virtual machine with just XP Pro SP3. When launching COLTT, the \"Components\" view is blank. There is no PMC installed in this VM but I don't think this is important. It seems richtx32.ocx is still not properly registered. Registering richtx32.ocx gets the component view up and proper.

comment:3 Changed 11 years ago by ahsanakhtar

Just to let you know that I haven't worked on this issue while building 1.08.3 MSI as I can't reprodue the problem here at SHMA. I have mentioned the issues that I fixed in the latest build in my email dated 19th October 2009.

To fix this issue, we need to have a PCNow session on your laptop. Can we have this on coming Monday? The second thing on which I need your advice is that in my opinion it will take lot of time to work on this because I will make changes in the MSI, will uploaded it on iBackup and then will download on your machine (The size of the MSI is about 21 MB). Would it be fine to work on this issue or to some other TRAC issue in which COLTT is changing the behavior of a run? Please advise.

comment:4 Changed 11 years ago by michelpons

No problem for a PCNow session on Monday dedicated to this issue but indeed transferring new MSIs will take some time. At first I thought the issue was limited to machines that had Aspen Hysys or UniSim Design installed. In fact, according to the tests I made yesterday, the issue is there for a machine without any PME installed. So my understanding is that the issue is indeed with the way richtx32.ocx is registered during installation. With other PMEs, I assume they are registering properly richtx32.ocx during their installation (i.e. with ProSim Plus, Aspen Plus, PRO/II) and the improper registration of richtx32.ocx during COLTT installation does not pop up. This issue can be damaging to the use of COLTT since it won't be easy to provide the necessary workaround procedure together with the installation or should we provide a ReadMe.txt file that would cover such issue?
So is there a way to figure out how richtx32.ocx is registered in a machine that has PRO/II or ProSim Plus installed and then compare?

comment:5 Changed 11 years ago by michelpons

Michael made the following proposal: \"I think that a possible workaround would be for Ahsan to add a .reg file containing the registry entries for richtx32.ocx to the .msi and to get the .msi to load that, that would avoid richtx32.ocx having to self-register but would achieve the same end.\"

comment:6 Changed 11 years ago by michelpons

  • Summary changed from COLTT 09-001 richtx32 ocx file not properly registered at installation to 09-001 richtx32 ocx file not properly registered at installation

comment:7 Changed 11 years ago by michelpons

I have made a test with COLTT 1.08.3 (Build Oct 27, 2009) in a VM where only UniSim Design had been installed. After its installation, COLTT 1.08.3 controller window opens up as it is supposed to. Additional tests in a VM with Aspen Hysys (where the defect was initially documented) have to be performed before closing the defect but this first result is encouraging.

comment:8 Changed 11 years ago by michelpons

  • Status changed from assigned to closed
  • Resolution set to fixed

I have also made a test in a machine with Aspen Hysys and I confirm that the 1.08.3 Build Oct 27, 2009 installer is doing fine regarding richtx32.ocx. Consequently I close this ticket.

comment:9 Changed 9 years ago by michelpons

  • Milestone set to Refactoring
Note: See TracTickets for help on using tickets.