Ticket #36 (closed defect: wontfix)

Opened 2 months ago

Last modified 2 months ago

Interface registrations remain

Reported by: jasper Owned by: michelpons
Priority: minor Milestone: 1.1 extension maintenance
Component: Build script Version: 2.1.2
Keywords: Cc:

Description

As a result of the initial 64-bit CAPE-OPEN type libraries being released having component IDs that are equal to the 32-bit type libraries, a side effect of having both installed and removing one after the other in separate installs confuses the microsoft installer tool into thinking that the component has already been uninstalled.

In this scenario interface registrations may remain for the last bitness removed, even if the corresponding files have been removed.

Change History

comment:1 Changed 2 months ago by jasper

This cannot be addressed for type libraries CAPE-OPEN-1.0.0 and CAPE-OPEN-1.1.0, as the component IDs as they are have already been released and cannot be changed.

The problem is corrected for CAPE-OPEN-1.1-ext and will not be there for any future type library.

comment:2 Changed 2 months ago by jasper

The collision of component IDs when including both the 32-bit merge module and 64-bit merge module in the same installer, in addition may cause installer compiler warnings, depending on the installer compiler used.

comment:3 Changed 2 months ago by jasper

The problem will disappear upon retiring CAPE-OPEN 1.0 and 1.1.

comment:4 Changed 2 months ago by michelpons

  • Status changed from new to closed
  • Version changed from 1.0 to 2.1.2
  • Resolution set to wontfix
  • Milestone set to 1.1 extension maintenance
Note: See TracTickets for help on using tickets.